Results 1 to 4 of 4

Thread: 5 speed Clutch with 6 speed gearbox problem

  1. #1
    Member Nick71's Avatar
    Join Date
    Feb 2016
    Location
    Brighton
    Posts
    82

    5 speed Clutch with 6 speed gearbox problem

    I'm using a 5 speed Competition clutches stage 4 clutch and flywheel on my Bugeye build with 6 speed 07 Hawkeye gearbox with 6 speed release fork and slave but can't get enough clearance at the arm to fit the slave. Am I missing something or is the clutch/flywheel the problem? Is there more than one type of slave cylinder?
    Last edited by Nick71; 6th June 2019 at 08:19.

  2. #2
    Senior Member
    Join Date
    Mar 2004
    Location
    oop north
    Posts
    3,464
    have always kept arm / slave as matched 5spd items or vice-versa.............

    not really sure why you would limit your clutch ability by retaining the 5spd anyhows

  3. #3
    Member Nick71's Avatar
    Join Date
    Feb 2016
    Location
    Brighton
    Posts
    82
    Quote Originally Posted by stockcar View Post
    have always kept arm / slave as matched 5spd items or vice-versa.............
    I am using a 6 speed arm and slave, just not sure if they differ by year? OR whether the issue lies elsewhere

    Quote Originally Posted by stockcar View Post
    not really sure why you would limit your clutch ability by retaining the 5spd anyhows
    cost mainly as already had a new clutch/flywheel. Also under the assumption that a stage 4 ceramic clutch will handle more than enough power/torque for my needs.

  4. #4
    Senior Member
    Join Date
    Mar 2004
    Location
    oop north
    Posts
    3,464
    when i said 'matching' i meant 5spd clutch to 5spd fork and vce-versa albeit we have run 5spd clutch set-up with 6spd stuff with no issue.......

    from memory New-age & Hatch 6spd slaves / forks are all the same

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •